xuliangzhan vxe-table vxe-textarea textarea.js export cross site scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
A vulnerability, which was classified as problematic, has been found in xuliangzhan vxe-table up to 3.7.9. This issue affects the function export of the file packages/textarea/src/textarea.js of the component vxe-textarea. The manipulation of the argument inputValue leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 3.7.10 is able to address this issue. The patch is named d70b0e089740b65a22c89c106ebc4627ac48a22d. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-266123.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| xuliangzhan | vxe-table | 3.7.0; 3.7.1; 3.7.2; 3.7.3; 3.7.4; 3.7.5; 3.7.6; 3.7.7; 3.7.8; 3.7.9 | — | No fix listed | CNA |
| — | vxe-table (npm) | before 3.7.10 | 3.7.10 | Patch available | GHSA-2qjp-fg8c-g878 |
- vxe-table Vendorxuliangzhan Affected 3.7.0; 3.7.1; 3.7.2; 3.7.3; 3.7.4; 3.7.5; 3.7.6; 3.7.7; 3.7.8; 3.7.9 Fixed in — No fix listed CNA
- vxe-table (npm) Vendor— Affected before 3.7.10 Fixed in 3.7.10 Patch available GHSA-2qjp-fg8c-g878
Remediation
- Fix · GHSA-2qjp-fg8c-g878 vxe-table (npm) Fixed in 3.7.10 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1001
- 2026-10-03 Alias added: GHSA-2qjp-fg8c-g878
References
Patch 2
Sources
- CVE-2023-1001 · CVE Program
- CVE-2023-1001 · NVD
- FIRST EPSS
- GHSA-2qjp-fg8c-g878 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences