WP SMTP Mailing Queue < 2.0.1 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The SMTP Mailing Queue WordPress plugin before 2.0.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00535 45th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by the CNA and NVD
Fix Fixed SMTP Mailing Queue (Unknown): 2.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | SMTP Mailing Queue | before 2.0.1 | 2.0.1 | Patch available | CNA |
- SMTP Mailing Queue VendorUnknown Affected before 2.0.1 Fixed in 2.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:smtp_mailing_queue_project:smtp_mailing_queue:*:*:*:*:*:wordpress:*:* | before 2.0.1 | Vulnerable | Smtp Mailing Queue Project |
- cpe:2.3:a:smtp_mailing_queue_project:smtp_mailing_queue:*:*:*:*:*:wordpress:*:* Versions before 2.0.1 Vulnerable ·Smtp Mailing Queue Project
Remediation
- Fix · CNA SMTP Mailing Queue (Unknown) Fixed in 2.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1090
- 2026-10-03 Alias added: GHSA-qxjq-7fh3-rmh9
References
Sources
- CVE-2023-1090 · CVE Program
- CVE-2023-1090 · NVD
- FIRST EPSS
- GHSA-qxjq-7fh3-rmh9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences