Simple Giveaways < 2.45.1 - Admin+ Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Simple Giveaways WordPress plugin before 2.45.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Simple Giveaways | before 2.45.1 | 2.45.1 | Patch available | CNA |
- Simple Giveaways VendorUnknown Affected before 2.45.1 Fixed in 2.45.1 Patch available CNA
Remediation
- Fix · CNA Simple Giveaways (Unknown) Fixed in 2.45.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Simple Giveaways 2.45.1
3 records Highest priority Priority MEDIUM 3 MEDIUM
Other records, highest priority first
- TI-2023-01062 Simple Giveaways < 2.45.1 - Editor+ Stored Cross-Site ScriptingPriority MEDIUM 55
- TI-2023-01061 Simple Giveaways < 2.45.1 - Admin+ Stored Cross-Site ScriptingPriority MEDIUM 55
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1120
- 2026-10-03 Alias added: GHSA-3jhg-69mr-g25w
References
More ibenic Simple Giveaways vulnerabilities
- TI-2023-01062 Simple Giveaways < 2.45.1 - Editor+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2023-01061 Simple Giveaways < 2.45.1 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
- TI-2023-14812 WordPress Simple Giveaways Plugin <= 2.46.0 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2021-06590 Simple Giveaways < 2.36.2 - Unauthenticated Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-1120 · CVE Program
- CVE-2023-1120 · NVD
- FIRST EPSS
- GHSA-3jhg-69mr-g25w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences