kylin-system-updater Update InstallSnap command injection
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-77.
Summary
A vulnerability, which was classified as critical, was found in kylin-system-updater up to 1.4.20kord on Ubuntu Kylin. Affected is the function InstallSnap of the component Update Handler. The manipulation leads to command injection. The attack needs to be approached locally. The exploit has been disclosed to the public and may be used. The identifier of this vulnerability is VDB-222600.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | kylin-system-updater | 1.4.20kord | — | No fix listed | CNA |
- kylin-system-updater Vendor— Affected 1.4.20kord Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:ubuntukylin:kylin-system-updater:*:*:*:*:*:*:*:* | up to 1.4.20kord | Vulnerable | Ubuntukylin |
- cpe:2.3:a:ubuntukylin:kylin-system-updater:*:*:*:*:*:*:*:* Versions up to 1.4.20kord Vulnerable ·Ubuntukylin
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1277
- 2026-10-03 Alias added: GHSA-mvh8-j583-3mwc
References
Sources
- CVE-2023-1277 · CVE Program
- CVE-2023-1277 · NVD
- FIRST EPSS
- GHSA-mvh8-j583-3mwc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences