W4 Post List < 2.4.6 - Subscriber+ Password Protected Post Content Disclosure
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-862.
Summary
The W4 Post List WordPress plugin before 2.4.6 does not ensure that password protected posts can be accessed before displaying their content, which could allow any authenticated users to access them
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | W4 Post List | before 2.4.6 | 2.4.6 | Patch available | CNA |
- W4 Post List VendorUnknown Affected before 2.4.6 Fixed in 2.4.6 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:w4_post_list_project:w4_post_list:*:*:*:*:*:wordpress:*:* | before 2.4.6 | Vulnerable | W4 Post List Project |
- cpe:2.3:a:w4_post_list_project:w4_post_list:*:*:*:*:*:wordpress:*:* Versions before 2.4.6 Vulnerable ·W4 Post List Project
Remediation
- Fix · CNA W4 Post List (Unknown) Fixed in 2.4.6
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
W4 Post List 2.4.6
3 records Highest priority Priority MEDIUM 3 MEDIUM
Other records, highest priority first
- TI-2023-01298 W4 Post List < 2.4.6 - Reflected XSSPriority MEDIUM 60
- TI-2023-00358 W4 Post List < 2.4.6 - Contributor+ Stored XSSPriority MEDIUM 58
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1371
- 2026-10-03 Alias added: GHSA-f99f-842c-6wrr
- 2026-10-13 EPSS moved to the 50th–90th percentile
References
More W4 Post List Project W4 Post List vulnerabilities
- TI-2023-01298 W4 Post List < 2.4.6 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-00358 W4 Post List < 2.4.6 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-12145 WordPress W4 Post List Plugin <= 2.4.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-1371 · CVE Program
- CVE-2023-1371 · NVD
- FIRST EPSS
- GHSA-f99f-842c-6wrr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences