Read the docs
TI-2023-01391 Aliases CVE-2023-1472GHSA-5v24-vjhg-w435

RapidLoad Power-Up for Autoptimize <= 1.7.1 - Cross-Site Request Forgery

Priority LOW 27CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The RapidLoad Power-Up for Autoptimize plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.7.1. This is due to missing or incorrect nonce validation on its AJAX actions. This makes it possible for unauthenticated attackers to invoke those functions, via forged request granted they can trick a site administrator into performing an action such as clicking on a link. Actions include resetting the API key, accessing or deleting log files, and deleting cache among others.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00209 11th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
shakee93RapidLoad AI – Optimize Web Vitals Automaticallyup to 1.7.1—No fix listedCNA
  • RapidLoad AI – Optimize Web Vitals Automatically Vendorshakee93 Affected up to 1.7.1 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:rapidload:rapidload_power-up_for_autoptimize:*:*:*:*:*:wordpress:*:*before 1.7.2Vulnerableshakee93
  • cpe:2.3:a:rapidload:rapidload_power-up_for_autoptimize:*:*:*:*:*:wordpress:*:* Versions before 1.7.2 Vulnerable ·shakee93

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-1472
  2. 2026-10-03 Alias added: GHSA-5v24-vjhg-w435

References

  • TI-2022-23631 WordPress RapidLoad Power-Up for Autoptimize Plugin <= 1.6.35 is vulnerable to SQL Injection CVSS 3.1HIGH 8.5
  • TI-2023-01263 RapidLoad Power-Up for Autoptimize <= 1.7.1 - Missing Authorization in 'clear_uucss_logs' CVSS 3.1MEDIUM 4.3
  • TI-2023-01265 RapidLoad Power-Up for Autoptimize <= 1.7.1 - Missing Authorization in 'uucss_update_rule' CVSS 3.1MEDIUM 4.3
  • TI-2023-01264 RapidLoad Power-Up for Autoptimize <= 1.7.1 - Missing Authorization in 'attach_rule' CVSS 3.1MEDIUM 4.3
  • TI-2023-01262 RapidLoad Power-Up for Autoptimize <= 1.7.1 - Missing Authorization in 'ajax_deactivate' CVSS 3.1MEDIUM 4.3
  • TI-2023-01261 RapidLoad Power-Up for Autoptimize <= 1.7.1 - Missing Authorization in 'ucss_connect' CVSS 3.1MEDIUM 4.3
See all 16 →

Sources