Cross-site Scripting (XSS) - Reflected in imgproxy/imgproxy
Priority MEDIUM 64CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Cross-site Scripting (XSS) - Reflected in GitHub repository imgproxy/imgproxy prior to 3.14.0.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01585 75th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed imgproxy/imgproxy (imgproxy): 3.14.0github.com/imgproxy/imgproxy/v3 (Go): 3.14.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| imgproxy | imgproxy/imgproxy | before 3.14.0 | 3.14.0 | Patch available | CNA |
| — | github.com/imgproxy/imgproxy/v3 (Go) | before 3.14.0 | 3.14.0 | Patch available | GHSA-ch9g-x9j7-rcgp |
- imgproxy/imgproxy Vendorimgproxy Affected before 3.14.0 Fixed in 3.14.0 Patch available CNA
- github.com/imgproxy/imgproxy/v3 (Go) Vendor— Affected before 3.14.0 Fixed in 3.14.0 Patch available GHSA-ch9g-x9j7-rcgp
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:evilmartians:imgproxy:*:*:*:*:*:*:*:* | before 3.14.0 | Vulnerable | Evilmartians |
- cpe:2.3:a:evilmartians:imgproxy:*:*:*:*:*:*:*:* Versions before 3.14.0 Vulnerable ·Evilmartians
Remediation
- Fix · CNA imgproxy/imgproxy (imgproxy) Fixed in 3.14.0
- Fix · GHSA-ch9g-x9j7-rcgp github.com/imgproxy/imgproxy/v3 (Go) Fixed in 3.14.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1496
- 2026-10-03 Alias added: GHSA-ch9g-x9j7-rcgp
References
More imgproxy vulnerabilities
- TI-2025-18097 imgproxy is vulnerable to SSRF against 0.0.0.0 CVSS 3.1MEDIUM 5.3
Sources
- CVE-2023-1496 · CVE Program
- CVE-2023-1496 · NVD
- FIRST EPSS
- GHSA-ch9g-x9j7-rcgp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences