WP Custom Author URL < 1.0.5 - Admin+ Stored XSS
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Custom Author URL WordPress plugin before 1.0.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00501 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Custom Author URL (Unknown): 1.0.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Custom Author URL | before 1.0.5 | 1.0.5 | Patch available | CNA |
- WP Custom Author URL VendorUnknown Affected before 1.0.5 Fixed in 1.0.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wp_custom_author_url_project:wp_custom_author_url:*:*:*:*:*:wordpress:*:* | before 1.0.5 | Vulnerable | Wp Custom Author Url Project |
- cpe:2.3:a:wp_custom_author_url_project:wp_custom_author_url:*:*:*:*:*:wordpress:*:* Versions before 1.0.5 Vulnerable ·Wp Custom Author Url Project
Remediation
- Fix · CNA WP Custom Author URL (Unknown) Fixed in 1.0.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1614
- 2026-10-03 Alias added: GHSA-g28w-x78f-228c
References
Sources
- CVE-2023-1614 · CVE Program
- CVE-2023-1614 · NVD
- FIRST EPSS
- GHSA-g28w-x78f-228c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences