Heap-based Buffer Overflow in gpac/gpac
Priority LOW 37CWE-122Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-122 and the CVSS impact.
Summary
Heap-based Buffer Overflow in GitHub repository gpac/gpac prior to 2.4.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00513 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed gpac/gpac (gpac): 2.4.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA gpac/gpac (gpac) Fixed in 2.4.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
gpac/gpac 2.4.0
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2023-01555 Denial of Service in gpac/gpacPriority LOW 34
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1655
- 2026-10-03 Alias added: GHSA-52jw-mw7h-6hfg
References
More Gpac vulnerabilities
- TI-2023-25004 An issue was discovered in gpac version 2.3-DEV-rev588-g7edc40fee-master, allows remote… CVSS 3.1CRITICAL 9.8
- TI-2025-43085 GPAC v2.4.0 was discovered to contain an out-of-bounds read in the oggdmx_parse_tags function. CVSS 3.1HIGH 8.2
- TI-2024-00295 Stack-based Buffer Overflow in gpac/gpac CVSS 3.1CRITICAL 9.8
- TI-2023-25341 Heap Buffer Overflow vulnerability in GPAC version 2.3-DEV-rev617-g671976fcc-master… CVSS 3.1CRITICAL 9.8
- TI-2023-02661 NULL Pointer Dereference in gpac/gpac CVSS 3.1CRITICAL 9.8
- TI-2026-22173 GPAC NHML Demuxer (dmx_nhml.c) Vulnerable to Stack Buffer Overflow CVSS 4.0HIGH 7.7
Sources
- CVE-2023-1655 · CVE Program
- CVE-2023-1655 · NVD
- FIRST EPSS
- GHSA-52jw-mw7h-6hfg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences