Code injection in GitLab
Priority HIGH 75CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-94.
Summary
An issue was identified in GitLab CE/EE affecting all versions from 1.0 prior to 15.8.5, 15.9 prior to 15.9.4, and 15.10 prior to 15.10.1 where non-printable characters gets copied from clipboard, allowing unexpected commands to be executed on victim machine.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01109 66th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 15.8.5, 15.9.4, 15.10.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 1.0 to before 15.8.5; 15.9 to before 15.9.4; 15.10 to before 15.10.1 | 15.8.5, 15.9.4, 15.10.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 1.0 to before 15.8.5; 15.9 to before 15.9.4; 15.10 to before 15.10.1 Fixed in 15.8.5, 15.9.4, 15.10.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 1.0.0 to before 15.8.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 1.0.0 to before 15.8.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.9.0 to before 15.9.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.9.0 to before 15.9.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:community:*:*:* | 15.10.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:enterprise:*:*:* | 15.10.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 1.0.0 to before 15.8.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 1.0.0 to before 15.8.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.9.0 to before 15.9.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.9.0 to before 15.9.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:community:*:*:* Versions 15.10.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:15.10.0:*:*:*:enterprise:*:*:* Versions 15.10.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 15.8.5, 15.9.4, 15.10.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1708
- 2026-10-03 Alias added: GHSA-phjw-j3fx-vxpj
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-1708 · CVE Program
- CVE-2023-1708 · NVD
- FIRST EPSS
- GHSA-phjw-j3fx-vxpj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences