Default Credential Vulnerability in GajShield Data Security Firewall
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass, Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-287 and CWE-522.
Summary
This vulnerability exists in GajShield Data Security Firewall firmware versions prior to v4.28 (except v4.21) due to insecure default credentials which allows remote attacker to login as superuser by using default username/password via web-based management interface and/or exposed SSH port thereby enabling remote attackers to execute arbitrary commands with administrative/superuser privileges on the targeted systems. The vulnerability has been addressed by forcing the user to change their default password to a new non-default password.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GajShield | Data Security Firewall | 4.5 to before 4.28 | 4.28, 4.21 | Patch available | CNA |
- Data Security Firewall VendorGajShield Affected 4.5 to before 4.28 Fixed in 4.28, 4.21 Patch available CNA
Remediation
- Fix · CNA Data Security Firewall (GajShield) Fixed in 4.28, 4.21
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1778
- 2026-10-03 Alias added: GHSA-f9gp-vxr4-29wq
References
Sources
- CVE-2023-1778 · CVE Program
- CVE-2023-1778 · NVD
- FIRST EPSS
- GHSA-f9gp-vxr4-29wq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences