Pgadmin: users authenticated simultaneously via ldap may be attached to the wrong session
Priority LOW 37CWE-488Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
A vulnerability was found in pgadmin. Users logging into pgAdmin running in server mode using LDAP authentication may be attached to another user's session if multiple connection attempts occur simultaneously.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00445 38th percentileScored 2026-11-07
Fix Fixed pgadmin: 7.0pgadmin4 (PyPI): 7.0
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pgadmin | before 7.0 | 7.0 | Patch available | CNA |
| — | pgadmin4 (PyPI) | before 7.0 | 7.0 | Patch available | GHSA-7w6r-748w-mh52 |
- pgadmin Vendor— Affected before 7.0 Fixed in 7.0 Patch available CNA
- pgadmin4 (PyPI) Vendor— Affected before 7.0 Fixed in 7.0 Patch available GHSA-7w6r-748w-mh52
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin:*:*:*:*:*:postgresql:*:* | before 7.0 | Vulnerable | pgadmin.org |
- cpe:2.3:a:pgadmin:pgadmin:*:*:*:*:*:postgresql:*:* Versions before 7.0 Vulnerable ·pgadmin.org
Remediation
- Fix · CNA pgadmin Fixed in 7.0
- Fix · GHSA-7w6r-748w-mh52 pgadmin4 (PyPI) Fixed in 7.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-1907
- 2026-10-03 Alias added: GHSA-7w6r-748w-mh52
References
Advisory 3
Other 4
Sources
- CVE-2023-1907 · CVE Program
- CVE-2023-1907 · NVD
- FIRST EPSS
- GHSA-7w6r-748w-mh52 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-1907 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences