Read the docs
TI-2023-01909 Aliases CVE-2023-2032GHSA-mr4p-2m35-4m4g

Custom 404 Pro < 3.8.1 - Multiple SQL Injection

Priority HIGH 82Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

The Custom 404 Pro WordPress plugin before 3.8.1 does not properly sanitize database inputs, leading to multiple SQL Injection vulnerabilities.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00934 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Custom 404 Pro (Unknown): 3.8.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownCustom 404 Probefore 3.8.13.8.1Patch availableCNA
  • Custom 404 Pro VendorUnknown Affected before 3.8.1 Fixed in 3.8.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:kunalnagar:custom_404_pro:*:*:*:*:*:wordpress:*:*before 3.8.1VulnerableKunal Nagar
  • cpe:2.3:a:kunalnagar:custom_404_pro:*:*:*:*:*:wordpress:*:* Versions before 3.8.1 Vulnerable ·Kunal Nagar

Remediation

  • Fix · CNA Custom 404 Pro (Unknown) Fixed in 3.8.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-2032
  2. 2026-10-03 Alias added: GHSA-mr4p-2m35-4m4g

References

  • TI-2023-01900 Custom 404 Pro < 3.7.3 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2022-23643 WordPress Custom 404 Pro Plugin <= 3.7.0 is vulnerable to SQL Injection (SQLi) CVSS 3.1HIGH 8.3
  • TI-2024-26570 WordPress Custom 404 Pro plugin <= 3.11.1 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
  • TI-2023-28192 WordPress Custom 404 Pro Plugin <= 3.10.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2019-10995 The Custom 404 Pro plugin 3.2.8 for WordPress has XSS via the wp-admin/admin.php?page=c4p-main page parameter. CVSS 3.0MEDIUM 6.1
  • TI-2019-11905 The custom-404-pro plugin before 3.2.8 for WordPress has reflected XSS, a different vulnerability than CVE-2019-14789. CVSS 3.0MEDIUM 6.1
See all 8 →

Sources