Exposure of resource to wrong sphere in GitLab
Priority MEDIUM 62CWE-668Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An issue has been discovered in GitLab affecting all versions starting from 10.0 before 12.9.8, all versions starting from 12.10 before 12.10.7, all versions starting from 13.0 before 13.0.1. A user with the role of developer could use the import project feature to leak CI/CD variables.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00811 57th percentileScored 2026-11-07
Fix Fixed GitLab (GitLab): 12.9.8, 12.10.7, 13.0.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 10.0 to before 12.9.8; 12.10 to before 12.10.7; 13.0 to before 13.0.1 | 12.9.8, 12.10.7, 13.0.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 10.0 to before 12.9.8; 12.10 to before 12.10.7; 13.0 to before 13.0.1 Fixed in 12.9.8, 12.10.7, 13.0.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:* | 10.0 to before 12.9.8; 12.10.0 to before 12.10.7; 13.0 to before 13.0.1 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:* Versions 10.0 to before 12.9.8; 12.10.0 to before 12.10.7; 13.0 to before 13.0.1 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 12.9.8, 12.10.7, 13.0.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2069
- 2026-10-03 Alias added: GHSA-6vqj-g5rm-3gp4
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-2069 · CVE Program
- CVE-2023-2069 · NVD
- FIRST EPSS
- GHSA-6vqj-g5rm-3gp4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences