Weak Password Requirements in janeczku/calibre-web
Priority HIGH 82CWE-521Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-521.
Summary
Weak Password Requirements in GitHub repository janeczku/calibre-web prior to 0.6.20.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00748 55th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed janeczku/calibre-web (janeczku): 0.6.20calibreweb (PyPI): 0.6.20
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| janeczku | janeczku/calibre-web | before 0.6.20 | 0.6.20 | Patch available | CNA |
| — | calibreweb (PyPI) | before 0.6.20 | 0.6.20 | Patch available | GHSA-mhmp-m6g7-7c24 |
- janeczku/calibre-web Vendorjaneczku Affected before 0.6.20 Fixed in 0.6.20 Patch available CNA
- calibreweb (PyPI) Vendor— Affected before 0.6.20 Fixed in 0.6.20 Patch available GHSA-mhmp-m6g7-7c24
Remediation
- Fix · CNA janeczku/calibre-web (janeczku) Fixed in 0.6.20
- Fix · GHSA-mhmp-m6g7-7c24 calibreweb (PyPI) Fixed in 0.6.20 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
janeczku/calibre-web 0.6.20
2 records Highest priority Priority HIGH 2 HIGH
Other records, highest priority first
- TI-2022-02333 Improper Restriction of Excessive Authentication Attempts in janeczku/calibre-webPriority HIGH 82
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2106
- 2026-10-03 Alias added: GHSA-mhmp-m6g7-7c24
References
More janeczku Calibre-web vulnerabilities
- TI-2022-02333 Improper Restriction of Excessive Authentication Attempts in janeczku/calibre-web CVSS 3.1CRITICAL 9.8
- TI-2021-07971 Calibre-web - Admin Account Takeover via Cross-Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2025-06745 Calibre Web 0.6.24 & Autocaliweb 0.7.0 - Blind C CVSS 4.0MEDIUM 5.9
- TI-2021-02885 Cross-site Scripting (XSS) in janeczku/calibre-web CVSS 3.1MEDIUM 6.1
- TI-2024-26178 In janeczku Calibre-Web 0.6.0 to 0.6.21, the edit_book_comments function is vulnerable to… CVSS 3.1MEDIUM 5.4
- TI-2021-07970 Stored Cross-Site Scripting (XSS) in Calibre-web via Description Field in Metadata CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-2106 · CVE Program
- CVE-2023-2106 · NVD
- FIRST EPSS
- GHSA-mhmp-m6g7-7c24 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences