Read the docs
TI-2023-02110 Aliases CVE-2023-2251GHSA-f9xv-q969-pqx4

Uncaught Exception in eemeli/yaml

Priority HIGH 72CWE-248Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-248.

Summary

Uncaught Exception in GitHub repository eemeli/yaml prior to 2.0.0-5.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01093 65th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed eemeli/yaml (eemeli): 2.0.0-5yaml (npm): 2.2.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
eemelieemeli/yamlbefore 2.0.0-52.0.0-5Patch availableCNA
—yaml (npm)2.0.0-5 to before 2.2.22.2.2Patch availableGHSA-f9xv-q969-pqx4
  • eemeli/yaml Vendoreemeli Affected before 2.0.0-5 Fixed in 2.0.0-5 Patch available CNA
  • yaml (npm) Vendor— Affected 2.0.0-5 to before 2.2.2 Fixed in 2.2.2 Patch available GHSA-f9xv-q969-pqx4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:yaml_project:yaml:*:*:*:*:*:node.js:*:*2.0.0-5 to before 2.2.2VulnerableYaml Project
  • cpe:2.3:a:yaml_project:yaml:*:*:*:*:*:node.js:*:* Versions 2.0.0-5 to before 2.2.2 Vulnerable ·Yaml Project

Remediation

  • Fix · CNA eemeli/yaml (eemeli) Fixed in 2.0.0-5
  • Fix · GHSA-f9xv-q969-pqx4 yaml (npm) Fixed in 2.2.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-2251
  2. 2026-10-03 Alias added: GHSA-f9xv-q969-pqx4

References

  • TI-2026-25925 yaml is vulnerable to Stack Overflow via deeply nested YAML collections CVSS 3.1MEDIUM 4.3

Sources