Ko-fi Button < 1.3.3 - Admin+ Stored XSS
Priority LOW 22CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Ko-fi Button WordPress plugin before 1.3.3 does not properly some of its settings, which could allow high-privilege users to perform Stored Cross-Site Scripting (XSS) attacks even when the unfiltered_html capability is disallowed (for example in multisite setup), and we consider it a low risk.
Why it matters now
EPSS 0.00442 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Ko-fi Button (Unknown): 1.3.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ko-fi Button | before 1.3.3 | 1.3.3 | Patch available | CNA |
- Ko-fi Button VendorUnknown Affected before 1.3.3 Fixed in 1.3.3 Patch available CNA
Remediation
- Fix · CNA Ko-fi Button (Unknown) Fixed in 1.3.3
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2254
- 2026-10-03 Alias added: GHSA-5x35-3c26-4v3r
References
Sources
- CVE-2023-2254 · CVE Program
- CVE-2023-2254 · NVD
- FIRST EPSS
- GHSA-5x35-3c26-4v3r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences