Read the docs
TI-2023-02208 Aliases CVE-2023-2352GHSA-w7x4-fmmp-fphm

CHP Ads Block Detector <= 3.9.4 - Cross-Site Request Forgery via chp_abd_action

Priority LOW 20CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The CHP Ads Block Detector plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.9.4. This is due to missing or incorrect nonce validation on the chp_abd_action function. This makes it possible for unauthenticated attackers to update or reset plugin settings via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00296 22nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
sureshchand12aCHP Ads Block Detectorup to 3.9.4—No fix listedCNA
  • CHP Ads Block Detector Vendorsureshchand12a Affected up to 3.9.4 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:sureshchand:chp_ads_block_detector:*:*:*:*:*:wordpress:*:*up to 3.9.4Vulnerablesureshchand12a
  • cpe:2.3:a:sureshchand:chp_ads_block_detector:*:*:*:*:*:wordpress:*:* Versions up to 3.9.4 Vulnerable ·sureshchand12a

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-2352
  2. 2026-10-03 Alias added: GHSA-w7x4-fmmp-fphm

References

  • TI-2023-02210 CHP Ads Block Detector <= 3.9.4 - Authenticated (Subscriber+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
  • TI-2023-02209 CHP Ads Block Detector <= 3.9.4 - Missing Authorization to Plugin Settings Update CVSS 3.1MEDIUM 4.3

Sources