Use of Out-of-range Pointer Offset in vim/vim
Priority MEDIUM 57CWE-823Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
Use of Out-of-range Pointer Offset in GitHub repository vim/vim prior to 9.0.1499.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00408 35th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed vim/vim (vim): 9.0.1499
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vim | vim/vim | before 9.0.1499 | 9.0.1499 | Patch available | CNA |
- vim/vim Vendorvim Affected before 9.0.1499 Fixed in 9.0.1499 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
| cpe:2.3:o:apple:macos:11.7.9:*:*:*:*:*:*:* | 11.7.9 | Vulnerable | Apple |
| cpe:2.3:o:apple:macos:12.6.8:*:*:*:*:*:*:* | 12.6.8 | Vulnerable | Apple |
| cpe:2.3:a:neovim:neovim:*:*:*:*:*:*:*:* | 0.7.0 to before 0.10.0 | Vulnerable | Neovim |
| cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* | before 9.0.1499 | Vulnerable | vim |
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
- cpe:2.3:o:apple:macos:11.7.9:*:*:*:*:*:*:* Versions 11.7.9 Vulnerable ·Apple
- cpe:2.3:o:apple:macos:12.6.8:*:*:*:*:*:*:* Versions 12.6.8 Vulnerable ·Apple
- cpe:2.3:a:neovim:neovim:*:*:*:*:*:*:*:* Versions 0.7.0 to before 0.10.0 Vulnerable ·Neovim
- cpe:2.3:a:vim:vim:*:*:*:*:*:*:*:* Versions before 9.0.1499 Vulnerable ·vim
Remediation
- Fix · CNA vim/vim (vim) Fixed in 9.0.1499
Vendor assessments
Red Hat
Red Hat rating: Low. Red Hat's page for this CVE →
Not affected: 4 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2426
- 2026-10-03 Alias added: GHSA-732j-vmpr-mg9v
References
More Vim vulnerabilities
- TI-2022-03248 Heap-based Buffer Overflow in vim/vim CVSS 3.1CRITICAL 9.8
- TI-2024-15103 Vim before 9.0.2142 has a stack-based buffer overflow because did_set_langmap in map.c… CVSS 3.1HIGH 7.8
- TI-2023-05093 Use After Free in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04407 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04379 Heap-based Buffer Overflow in vim/vim CVSS 3.1HIGH 7.8
- TI-2023-04378 Use After Free in vim/vim CVSS 3.1HIGH 7.8
Sources
- CVE-2023-2426 · CVE Program
- CVE-2023-2426 · NVD
- FIRST EPSS
- GHSA-732j-vmpr-mg9v · GitHub Advisory Database · CC BY 4.0
- CVE-2023-2426 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences