Read the docs
TI-2023-02400 Aliases CVE-2023-2568GHSA-m7j5-3qqf-3ccj

Photo Gallery by Ays < 5.1.7 - Reflected XSS

Priority MEDIUM 60Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

The Photo Gallery by Ays WordPress plugin before 5.1.7 does not escape some parameters before outputting it back in attributes, leading to Reflected Cross-Site Scripting which could be used against high privilege users such as admin

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00458 39th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Photo Gallery by Ays (Unknown): 5.1.7

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownPhoto Gallery by Aysbefore 5.1.75.1.7Patch availableCNA
  • Photo Gallery by Ays VendorUnknown Affected before 5.1.7 Fixed in 5.1.7 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ays-pro:photo_gallery:*:*:*:*:*:wordpress:*:*before 5.1.7VulnerableAys Pro
  • cpe:2.3:a:ays-pro:photo_gallery:*:*:*:*:*:wordpress:*:* Versions before 5.1.7 Vulnerable ·Ays Pro

Remediation

  • Fix · CNA Photo Gallery by Ays (Unknown) Fixed in 5.1.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-2568
  2. 2026-10-03 Alias added: GHSA-m7j5-3qqf-3ccj

References

  • TI-2016-08959 The gallery-photo-gallery plugin before 1.0.1 for WordPress has SQL injection. CVSS 3.0CRITICAL 9.8
  • TI-2021-06751 Photo Gallery by Ays - Responsive Image Gallery < 4.4.4 - Authenticated Blind SQL Injections CVSS 3.1HIGH 8.8
  • TI-2023-20816 WordPress Photo Gallery by Ays Plugin <= 5.2.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-15410 WordPress Photo Gallery by Ays Plugin <= 5.1.3 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2024-24946 WordPress Photo Gallery by Ays – Responsive Image Gallery plugin < 5.7.1 - HTML Injection vulnerability CVSS 3.1MEDIUM 5.5

Sources