Buy Me a Coffee < 3.7 - Admin+ Stored XSS
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Buy Me a Coffee WordPress plugin before 3.7 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0047 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Buy Me a Coffee (Unknown): 3.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Buy Me a Coffee | before 3.7 | 3.7 | Patch available | CNA |
- Buy Me a Coffee VendorUnknown Affected before 3.7 Fixed in 3.7 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:buymeacoffee:buy_me_a_coffee:*:*:*:*:*:wordpress:*:* | before 3.7 | Vulnerable | buymeacoffee |
- cpe:2.3:a:buymeacoffee:buy_me_a_coffee:*:*:*:*:*:wordpress:*:* Versions before 3.7 Vulnerable ·buymeacoffee
Remediation
- Fix · CNA Buy Me a Coffee (Unknown) Fixed in 3.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2578
- 2026-10-03 Alias added: GHSA-xmhp-p9h6-3cqm
References
More buymeacoffee Buy Me A Coffee vulnerabilities
- TI-2023-01954 Buy Me a Coffee – Button and Widget Plugin <= 3.7 - Missing Authorization CVSS 3.1HIGH 7.3
- TI-2023-01955 Buy Me a Coffee – Button and Widget Plugin <= 3.7 - Cross-Site Request Forgery CVSS 3.1HIGH 7.1
- TI-2023-01957 Buy Me a Coffee – Button and Widget Plugin <= 3.6 - Authenticated (Subscriber+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
- TI-2023-10503 WordPress Buy Me a Coffee plugin <= 3.7 - Broken Access Control vulnerability CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-2578 · CVE Program
- CVE-2023-2578 · NVD
- FIRST EPSS
- GHSA-xmhp-p9h6-3cqm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences