FormCraft Premium < 3.9.7 - Admin+ SQLi
Priority HIGH 67CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The FormCraft WordPress plugin before 3.9.7 does not properly sanitise and escape a parameter before using it in a SQL statement, leading to a SQL injection exploitable by high privilege users such as admin.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0085 58th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed FormCraft (Unknown): 3.9.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | FormCraft | 3.8.2 to before 3.9.7 | 3.9.7 | Patch available | CNA |
- FormCraft VendorUnknown Affected 3.8.2 to before 3.9.7 Fixed in 3.9.7 Patch available CNA
Remediation
- Fix · CNA FormCraft (Unknown) Fixed in 3.9.7
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2592
- 2026-10-03 Alias added: GHSA-78wc-m3h8-p6cc
References
More nCrafts Formcraft vulnerabilities
- TI-2019-04216 Cross-site request forgery in nCrafts FormCraft CVSS 3.0HIGH 8.8
- TI-2013-05877 SQL injection vulnerability in form.php in the FormCraft plugin 1.3.7 and earlier for… CVSS 2.0HIGH 7.5
- TI-2019-11285 The formcraft-form-builder plugin before 1.2.2 for WordPress has CSRF. CVSS 3.0HIGH 8.8
- TI-2025-00689 FormCraft - Premium WordPress Form Builder <= 3.9.11 - Unauthenticated Stored Cross-Site Scripting via SVG File Upload CVSS 3.1HIGH 7.2
- TI-2023-08892 WordPress FormCraft Plugin <= 1.2.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2017-13773 The formcraft3 plugin before 3.4 for WordPress has stored XSS via the "New Form > Heading > Heading Text" field. CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-2592 · CVE Program
- CVE-2023-2592 · NVD
- FIRST EPSS
- GHSA-78wc-m3h8-p6cc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences