Read the docs
TI-2023-02618 Aliases CVE-2023-2795GHSA-qp4h-5pwc-hqm5

CodeColorer < 0.10.1 – Admin+ Stored Cross-Site Scripting

Priority MEDIUM 55Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA.

Summary

The CodeColorer WordPress plugin before 0.10.1 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00442 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed CodeColorer (Unknown): 0.10.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownCodeColorerbefore 0.10.10.10.1Patch availableCNA
  • CodeColorer VendorUnknown Affected before 0.10.1 Fixed in 0.10.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:codecolorer_project:codecolorer:*:*:*:*:*:wordpress:*:*before 0.10.1VulnerableCodecolorer Project
  • cpe:2.3:a:codecolorer_project:codecolorer:*:*:*:*:*:wordpress:*:* Versions before 0.10.1 Vulnerable ·Codecolorer Project

Remediation

  • Fix · CNA CodeColorer (Unknown) Fixed in 0.10.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-2795
  2. 2026-10-03 Alias added: GHSA-qp4h-5pwc-hqm5

References

Sources