Out-of-bounds write in Wireshark
Priority MEDIUM 62CWE-787Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 4 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-787 and the CVSS impact.
Summary
VMS TCPIPtrace file parser crash in Wireshark 4.0.0 to 4.0.5 and 3.6.0 to 3.6.13 allows denial of service via crafted capture file
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01787 78th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial Wireshark (Wireshark Foundation): 4.0.6, 3.6.14Red Hat: 2 advisoriesRed Hat: 4 fixed, 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wireshark Foundation | Wireshark | 4.0.0 to before 4.0.6; 3.6.0 to before 3.6.14 | 4.0.6, 3.6.14 | Patch available | CNA |
- Wireshark VendorWireshark Foundation Affected 4.0.0 to before 4.0.6; 3.6.0 to before 3.6.14 Fixed in 4.0.6, 3.6.14 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wireshark:wireshark:*:*:*:*:*:*:*:* | 3.6.0 to before 3.6.14; 4.0.0 to before 4.0.6 | Vulnerable | Wireshark Foundation |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* | 12.0 | Vulnerable | Debian |
- cpe:2.3:a:wireshark:wireshark:*:*:*:*:*:*:*:* Versions 3.6.0 to before 3.6.14; 4.0.0 to before 4.0.6 Vulnerable ·Wireshark Foundation
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* Versions 12.0 Vulnerable ·Debian
Remediation
- Fix · CNA Wireshark (Wireshark Foundation) Fixed in 4.0.6, 3.6.14
Red Hat 2 advisories
- RHSA-2023:7015 Released 2023-11-14 · Red Hat rating Moderatewireshark security update
- Red Hat CodeReady Linux Builder (v. 8) wireshark-devel-1:2.6.2-17.el8
- Red Hat Enterprise Linux AppStream (v. 8) wireshark-1:2.6.2-17.el8, wireshark-cli-1:2.6.2-17.el8
- RHSA-2023:6469 Released 2023-11-07 · Red Hat rating Moderatewireshark security update
- Red Hat CodeReady Linux Builder (v. 9) wireshark-devel-1:3.4.10-6.el9
- Red Hat Enterprise Linux AppStream (v. 9) wireshark-1:3.4.10-6.el9, wireshark-cli-1:3.4.10-6.el9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 6 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2023:7015 |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2023:6469 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:7015 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:6469 |
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2856
- 2026-10-03 Alias added: GHSA-c9g4-j4fr-ggh2
References
More Wireshark Foundation Wireshark vulnerabilities
- TI-2026-53718 Heap-based Buffer Overflow in Wireshark CVSS 3.1CRITICAL 9.8
- TI-2026-63612 Heap-based Buffer Overflow in Wireshark CVSS 3.1HIGH 8.8
- TI-2024-16149 A buffer overflow in Wireshark before 4.2.0 allows a remote attacker to cause a denial of… CVSS 3.1HIGH 7.5
- TI-2010-00291 Multiple buffer overflows in the LWRES dissector in Wireshark 0.9.15 through 1.0.10 and… CVSS 2.0HIGH 7.5
- TI-2026-63614 Heap-based Buffer Overflow in Wireshark CVSS 3.1HIGH 8.1
- TI-2014-01823 Buffer overflow in the mpeg_read function in wiretap/mpeg.c in the MPEG parser in… CVSS 2.0HIGH 9.3
Sources
- CVE-2023-2856 · CVE Program
- CVE-2023-2856 · NVD
- FIRST EPSS
- GHSA-c9g4-j4fr-ggh2 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-2856 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences