TinyMCE Custom Styles < 1.1.4 - Admin+ Stored Cross-Site Scripting
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The TinyMCE Custom Styles WordPress plugin before 1.1.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00542 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed TinyMCE Custom Styles (Unknown): 1.1.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | TinyMCE Custom Styles | before 1.1.4 | 1.1.4 | Patch available | CNA |
- TinyMCE Custom Styles VendorUnknown Affected before 1.1.4 Fixed in 1.1.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:tinymce_custom_styles_project:tinymce_custom_styles:*:*:*:*:*:wordpress:*:* | before 1.1.4 | Vulnerable | Tinymce Custom Styles Project |
- cpe:2.3:a:tinymce_custom_styles_project:tinymce_custom_styles:*:*:*:*:*:wordpress:*:* Versions before 1.1.4 Vulnerable ·Tinymce Custom Styles Project
Remediation
- Fix · CNA TinyMCE Custom Styles (Unknown) Fixed in 1.1.4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2967
- 2026-10-03 Alias added: GHSA-p492-c975-6xjf
References
More Tinymce Custom Styles Project Tinymce Custom Styles vulnerabilities
- TI-2023-09782 WordPress TinyMCE Custom Styles Plugin <= 1.1.2 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
Sources
- CVE-2023-2967 · CVE Program
- CVE-2023-2967 · NVD
- FIRST EPSS
- GHSA-p492-c975-6xjf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences