Undefined variable usage in npm package "proxy" leads to remote denial of service
Priority MEDIUM 42CWE-232Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
A remote attacker can trigger a denial of service in the socket.remoteAddress variable, by sending a crafted HTTP request. Usage of the undefined variable raises a TypeError exception.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01478 74th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed proxy: 2.1.1proxy (npm): 2.1.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | proxy | before 2.1.1 | 2.1.1 | Patch available | CNA |
| — | proxy (npm) | 2.0.0 to before 2.1.1 | 2.1.1 | Patch available | GHSA-mj6p-3pc9-wf5m |
- proxy Vendor— Affected before 2.1.1 Fixed in 2.1.1 Patch available CNA
- proxy (npm) Vendor— Affected 2.0.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-mj6p-3pc9-wf5m
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:proxy_project:proxy:*:*:*:*:*:node.js:*:* | 2.0.0 to before 2.1.1 | Vulnerable | Proxy Project |
- cpe:2.3:a:proxy_project:proxy:*:*:*:*:*:node.js:*:* Versions 2.0.0 to before 2.1.1 Vulnerable ·Proxy Project
Remediation
- Fix · CNA proxy Fixed in 2.1.1
- Fix · GHSA-mj6p-3pc9-wf5m proxy (npm) Fixed in 2.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-2968
- 2026-10-03 Alias added: GHSA-mj6p-3pc9-wf5m
References
Sources
- CVE-2023-2968 · CVE Program
- CVE-2023-2968 · NVD
- FIRST EPSS
- GHSA-mj6p-3pc9-wf5m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences