Type confusion in Google Chrome
Priority CRITICAL 97Exploited in the wildCWE-843Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-843 and the CVSS impact.
Summary
Type confusion in V8 in Google Chrome prior to 114.0.5735.110 allowed a remote attacker to potentially exploit heap corruption via a crafted HTML page. (Chromium security severity: High)
Why it matters now
Exploitation Active In CISA KEV since 2023-06-07CISA due date 2023-06-28
EPSS 0.37858 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Chrome (Google): 114.0.5735.110
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Chrome | 114.0.5735.110 to before 114.0.5735.110 | 114.0.5735.110 | Patch available | CNA |
- Chrome VendorGoogle Affected 114.0.5735.110 to before 114.0.5735.110 Fixed in 114.0.5735.110 Patch available CNA
CPE configurations NVD · 7
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* | before 114.0.5735.110 | Vulnerable | |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* | 12.0 | Vulnerable | Debian |
| cpe:2.3:a:couchbase:couchbase_server:*:*:*:*:*:*:*:* | before 7.1.5 | Vulnerable | Couchbase |
| cpe:2.3:a:couchbase:couchbase_server:7.2.0:*:*:*:*:*:*:* | 7.2.0 | Vulnerable | Couchbase |
- cpe:2.3:a:google:chrome:*:*:*:*:*:*:*:* Versions before 114.0.5735.110 Vulnerable ·Google
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:12.0:*:*:*:*:*:*:* Versions 12.0 Vulnerable ·Debian
- cpe:2.3:a:couchbase:couchbase_server:*:*:*:*:*:*:*:* Versions before 7.1.5 Vulnerable ·Couchbase
- cpe:2.3:a:couchbase:couchbase_server:7.2.0:*:*:*:*:*:*:* Versions 7.2.0 Vulnerable ·Couchbase
Remediation
- Fix · CNA Chrome (Google) Fixed in 114.0.5735.110
Vendor assessments
Timeline
- 2023-06-07 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2023-3079
- 2026-10-03 Alias added: GHSA-8mwf-hvfp-6xfg
References
Exploit 1
Advisory 9
- https://chromereleases.googleblog.com/2023/06/stable-channel-update-for-desktop.html
- https://www.couchbase.com/alerts/
- https://www.debian.org/security/2023/dsa-5420
- https://lists.fedoraproject.org/archives/list/[email protected]/message/DYTXO5E3FI3I2ETDP3HF4SHYYTFMKMIC/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/U4OXTNIZY4JYHJT7CVLPAJQILI6BISVM/
- https://security.gentoo.org/glsa/202311-11
- http://packetstormsecurity.com/files/176211/Chrome-V8-Type-Confusion.html
- http://packetstormsecurity.com/files/176212/Chrome-V8-Type-Confusion-New-Sandbox-Escape.html
- https://security.gentoo.org/glsa/202401-34
More Google Chrome vulnerabilities
- TI-2025-09686 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.8
- TI-2024-07390 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04898 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04600 Type confusion in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2024-04346 Use after free in Google Chrome KEVCVSS 3.1CRITICAL 9.6
- TI-2023-05824 Integer overflow in Google Chrome KEVCVSS 3.1CRITICAL 9.6
Sources
- CVE-2023-3079 · CVE Program
- CVE-2023-3079 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-8mwf-hvfp-6xfg · GitHub Advisory Database · CC BY 4.0
- CVE-2023-3079 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences