Short URL < 1.6.5 - Admin+ Cross Site Scripting
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Short URL WordPress plugin before 1.6.5 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00501 43rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Short URL (Unknown): 1.6.5
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Short URL | before 1.6.5 | 1.6.5 | Patch available | CNA |
- Short URL VendorUnknown Affected before 1.6.5 Fixed in 1.6.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:kaizencoders:short_url:*:*:*:*:*:wordpress:*:* | before 1.6.5 | Vulnerable | KaizenCoders |
- cpe:2.3:a:kaizencoders:short_url:*:*:*:*:*:wordpress:*:* Versions before 1.6.5 Vulnerable ·KaizenCoders
Remediation
- Fix · CNA Short URL (Unknown) Fixed in 1.6.5
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3130
- 2026-10-03 Alias added: GHSA-5rc6-vfrf-3px8
References
More KaizenCoders Short Url vulnerabilities
- TI-2022-23204 WordPress Short URL Plugin <= 1.6.4 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-02737 Short URL <= 1.6.8 - Subscriber+ SQLi CVSS 3.1HIGH 8.8
- TI-2023-24106 WordPress Short URL Plugin <= 1.6.8 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2024-21213 WordPress Short URL plugin <= 1.6.8 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-01507 The Short URL plugin for WordPress is vulnerable to stored Cross-Site Scripting via the… CVSS 3.1MEDIUM 4.8
Sources
- CVE-2023-3130 · CVE Program
- CVE-2023-3130 · NVD
- FIRST EPSS
- GHSA-5rc6-vfrf-3px8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences