Weaver Show Posts < 1.8.1 - Admin+ PHP Object Injection
Priority MEDIUM 49CWE-502Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-502.
Summary
The Weaver Show Posts WordPress plugin before 1.8.1 unserialises the content of an imported file, which could lead to PHP object injections issues when a high privilege user import a malicious file and a suitable gadget chain is present on the blog.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00237 14th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed Weaver Show Posts (Unknown): 1.8.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Weaver Show Posts | before 1.8.1 | 1.8.1 | Patch available | CNA |
- Weaver Show Posts VendorUnknown Affected before 1.8.1 Fixed in 1.8.1 Patch available CNA
Remediation
- Fix · CNA Weaver Show Posts (Unknown) Fixed in 1.8.1
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3360
- 2026-10-03 Alias added: GHSA-xw87-h6v2-j87m
References
Sources
- CVE-2023-3360 · CVE Program
- CVE-2023-3360 · NVD
- FIRST EPSS
- GHSA-xw87-h6v2-j87m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences