Robo Gallery < 3.2.16 - Admin+ Stored XSS
Priority MEDIUM 55Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Photo Gallery, Images, Slider in Rbs Image Gallery WordPress plugin before 3.2.16 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0047 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Photo Gallery, Images, Slider in Rbs Image Gallery (Unknown): 3.2.16
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Photo Gallery, Images, Slider in Rbs Image Gallery | before 3.2.16 | 3.2.16 | Patch available | CNA |
- Photo Gallery, Images, Slider in Rbs Image Gallery VendorUnknown Affected before 3.2.16 Fixed in 3.2.16 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:robogallery:robo_gallery:*:*:*:*:*:wordpress:*:* | before 3.2.16 | Vulnerable | Robogallery |
- cpe:2.3:a:robogallery:robo_gallery:*:*:*:*:*:wordpress:*:* Versions before 3.2.16 Vulnerable ·Robogallery
Remediation
- Fix · CNA Photo Gallery, Images, Slider in Rbs Image Gallery (Unknown) Fixed in 3.2.16
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3499
- 2026-10-03 Alias added: GHSA-6593-m9wf-6mf9
References
More Robogallery Robo Gallery vulnerabilities
- TI-2023-12330 WordPress Robo Gallery Plugin <= 3.2.12 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2024-03636 Cross-site scripting in robosoft Robo Gallery – Photo & Image Slider CVSS 3.1MEDIUM 6.4
- TI-2024-14882 WordPress Robo Gallery Plugin <= 3.2.17 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 5.9
- TI-2022-22608 WordPress Robo Gallery Plugin <= 3.2.9 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1MEDIUM 5.4
Sources
- CVE-2023-3499 · CVE Program
- CVE-2023-3499 · NVD
- FIRST EPSS
- GHSA-6593-m9wf-6mf9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences