ksmbd: fix out-of-bound read in smb2_write
Priority LOW 36CWE-125Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix out-of-bound read in smb2_write ksmbd_smb2_check_message doesn't validate hdr->NextCommand. If ->NextCommand is bigger than Offset + Length of smb2 write, It will allow oversized smb2 write length. It will cause OOB read in smb2_write.
Why it matters now
EPSS 0.00649 51st percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.15.121, 6.1.36, 6.3.10 +1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Linux | Linux | 5.15 and later | 5.15.121, 6.1.36, 6.3.10, 6.4 | Patch available | CNA |
- Linux VendorLinux Affected 5.15 and later Fixed in 5.15.121, 6.1.36, 6.3.10, 6.4 Patch available CNA
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* | 5.15 to before 5.15.121; 5.16 to before 6.1.36; 6.2 to before 6.3.10 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc1:*:*:*:*:*:* | 6.4 rc1 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc2:*:*:*:*:*:* | 6.4 rc2 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc3:*:*:*:*:*:* | 6.4 rc3 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc4:*:*:*:*:*:* | 6.4 rc4 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc5:*:*:*:*:*:* | 6.4 rc5 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc6:*:*:*:*:*:* | 6.4 rc6 | Vulnerable | Linux |
| cpe:2.3:o:linux:linux_kernel:6.4:rc7:*:*:*:*:*:* | 6.4 rc7 | Vulnerable | Linux |
- cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.15 to before 5.15.121; 5.16 to before 6.1.36; 6.2 to before 6.3.10 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc1:*:*:*:*:*:* Versions 6.4 rc1 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc2:*:*:*:*:*:* Versions 6.4 rc2 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc3:*:*:*:*:*:* Versions 6.4 rc3 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc4:*:*:*:*:*:* Versions 6.4 rc4 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc5:*:*:*:*:*:* Versions 6.4 rc5 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc6:*:*:*:*:*:* Versions 6.4 rc6 Vulnerable ·Linux
- cpe:2.3:o:linux:linux_kernel:6.4:rc7:*:*:*:*:*:* Versions 6.4 rc7 Vulnerable ·Linux
Remediation
- Fix · CNA Linux (Linux) Fixed in 5.15.121, 6.1.36, 6.3.10, 6.4
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 5 products
- Red Hat Enterprise Linux 10
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
- Red Hat Enterprise Linux 8
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3865
- 2026-10-03 Alias added: GHSA-mr68-gqxj-cfm9
- 2026-10-30 EPSS moved to the 50th–90th percentile
References
More Linux Kernel vulnerabilities
- TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
- TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
- TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
- TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
- TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
- TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
Sources
- CVE-2023-3865 · CVE Program
- CVE-2023-3865 · NVD
- FIRST EPSS
- GHSA-mr68-gqxj-cfm9 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-3865 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences