Improper Validation of Specified Type of Input in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
An input validation issue in the asset proxy in GitLab EE, affecting all versions from 12.3 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1, allowed an authenticated attacker to craft image urls which bypass the asset proxy.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 12.3 to before 16.2.8; 16.3 to before 16.3.5; 16.4 to before 16.4.1 | 16.2.8, 16.3.5, 16.4.1 | Patch available | CNA |
- GitLab VendorGitLab Affected 12.3 to before 16.2.8; 16.3 to before 16.3.5; 16.4 to before 16.4.1 Fixed in 16.2.8, 16.3.5, 16.4.1 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 12.3 to before 16.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 12.3 to before 16.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.3.0 to before 16.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.3.0 to before 16.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.4.0:*:*:*:community:*:*:* | 16.4.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.4.0:*:*:*:enterprise:*:*:* | 16.4.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 12.3 to before 16.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 12.3 to before 16.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.3.0 to before 16.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.3.0 to before 16.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.4.0:*:*:*:community:*:*:* Versions 16.4.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.4.0:*:*:*:enterprise:*:*:* Versions 16.4.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.2.8, 16.3.5, 16.4.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 16.2.8, 16.3.5, 16.4.1
11 records Highest priority Priority HIGH 2 HIGH, 6 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2023-03652 Improper Validation of Specified Type of Input in GitLabPriority HIGH 66
- TI-2023-03191 Insertion of Sensitive Information Into Sent Data in GitLabPriority HIGH 66
- TI-2023-03654 URL Redirection to Untrusted Site ('Open Redirect') in GitLabPriority MEDIUM 64
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3906
- 2026-10-03 Alias added: GHSA-x2v6-6q9m-6qx9
References
Exploit 1
Advisory 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-3906 · CVE Program
- CVE-2023-3906 · NVD
- FIRST EPSS
- GHSA-x2v6-6q9m-6qx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences