Wibu: Buffer Overflow in CodeMeter Runtime
Priority MEDIUM 53CWE-787Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
A heap buffer overflow vulnerability in Wibu CodeMeter Runtime network service up to version 7.60b allows an unauthenticated, remote attacker to achieve RCE and gain full access of the host system.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01971 80th percentileScored 2026-11-07
Fix Fixed CodeMeter Runtime (Wibu): 7.21g
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Wibu | CodeMeter Runtime | 0.0 – 7.60b | — | No fix listed | CNA |
| Wibu | CodeMeter Runtime | — | 7.21g | Patch available | CNA |
- CodeMeter Runtime VendorWibu Affected 0.0 – 7.60b Fixed in — No fix listed CNA
- CodeMeter Runtime VendorWibu Affected — Fixed in 7.21g Patch available CNA
CPE configurations NVD · 25
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wibu:codemeter_runtime:*:*:*:*:*:*:*:* | before 7.60c | Vulnerable | Wibu |
| cpe:2.3:a:trumpf:oseon:*:*:*:*:*:*:*:* | 1.0.0 – 3.0.22 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:programmingtube:*:*:*:*:*:*:*:* | 1.0.1 – 4.6.3 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:teczonebend:*:*:*:*:*:*:*:* | 18.02.r8 – 23.06.01 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:tops_unfold:05.03.00.00:*:*:*:*:*:*:* | 05.03.00.00 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:topscalculation:*:*:*:*:*:*:*:* | 14.00 – 22.00.00 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trumpflicenseexpert:*:*:*:*:*:*:*:* | 1.5.2 – 1.11.1 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutops:*:*:*:*:*:*:*:* | 08.00 – 12.01.00.00 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutops_cell_classic:*:*:*:*:*:*:*:* | up to 09.09.02 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutops_cell_sw48:*:*:*:*:*:*:*:* | 01.00 – 02.26.0 | Vulnerable | TRUMPF |
- cpe:2.3:a:wibu:codemeter_runtime:*:*:*:*:*:*:*:* Versions before 7.60c Vulnerable ·Wibu
- cpe:2.3:a:trumpf:oseon:*:*:*:*:*:*:*:* Versions 1.0.0 – 3.0.22 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:programmingtube:*:*:*:*:*:*:*:* Versions 1.0.1 – 4.6.3 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:teczonebend:*:*:*:*:*:*:*:* Versions 18.02.r8 – 23.06.01 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:tops_unfold:05.03.00.00:*:*:*:*:*:*:* Versions 05.03.00.00 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:topscalculation:*:*:*:*:*:*:*:* Versions 14.00 – 22.00.00 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trumpflicenseexpert:*:*:*:*:*:*:*:* Versions 1.5.2 – 1.11.1 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutops:*:*:*:*:*:*:*:* Versions 08.00 – 12.01.00.00 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutops_cell_classic:*:*:*:*:*:*:*:* Versions up to 09.09.02 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutops_cell_sw48:*:*:*:*:*:*:*:* Versions 01.00 – 02.26.0 Vulnerable ·TRUMPF
Show 15 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:trumpf:trutops_mark_3d:*:*:*:*:*:*:*:* | 01.00 – 06.01 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutopsboost:*:*:*:*:*:*:*:* | 06.00.23.00 – 16.0.22 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutopsfab:*:*:*:*:*:*:*:* | 15.00.23.00 – 22.8.25 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutopsfab_storage_smallstore:*:*:*:*:*:*:*:* | 14.06.20 – 20.04.20.00 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutopsprint:*:*:*:*:*:*:*:* | 00.06.00 – 01.00 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutopsprintmultilaserassistant:*:*:*:*:*:*:*:* | 01.02 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:trutopsweld:*:*:*:*:*:*:*:* | 7.0.198.241 – 9.0.28148.1 | Vulnerable | TRUMPF |
| cpe:2.3:a:trumpf:tubedesign:*:*:*:*:*:*:*:* | 08.00 – 14.06.150 | Vulnerable | TRUMPF |
| cpe:2.3:a:phoenixcontact:activation_wizard:*:*:*:*:*:moryx:*:* | up to 1.6 | Vulnerable | Phoenixcontact |
| cpe:2.3:a:phoenixcontact:e-mobility_charging_suite:*:*:*:*:*:*:*:* | up to 1.7.0 | Vulnerable | Phoenixcontact |
| cpe:2.3:a:phoenixcontact:fl_network_manager:*:*:*:*:*:*:*:* | up to 7.0 | Vulnerable | Phoenixcontact |
| cpe:2.3:a:phoenixcontact:iol-conf:*:*:*:*:*:*:*:* | up to 1.7.0 | Vulnerable | Phoenixcontact |
| cpe:2.3:a:phoenixcontact:module_type_package_designer:*:*:*:*:*:*:*:* | before 1.2.0 | Vulnerable | Phoenixcontact |
| cpe:2.3:a:phoenixcontact:module_type_package_designer:1.2.0:beta:*:*:*:*:*:* | 1.2.0 beta | Vulnerable | Phoenixcontact |
| cpe:2.3:a:phoenixcontact:plcnext_engineer:*:*:*:*:*:*:*:* | up to 2023.6 | Vulnerable | Phoenixcontact |
- cpe:2.3:a:trumpf:trutops_mark_3d:*:*:*:*:*:*:*:* Versions 01.00 – 06.01 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutopsboost:*:*:*:*:*:*:*:* Versions 06.00.23.00 – 16.0.22 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutopsfab:*:*:*:*:*:*:*:* Versions 15.00.23.00 – 22.8.25 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutopsfab_storage_smallstore:*:*:*:*:*:*:*:* Versions 14.06.20 – 20.04.20.00 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutopsprint:*:*:*:*:*:*:*:* Versions 00.06.00 – 01.00 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutopsprintmultilaserassistant:*:*:*:*:*:*:*:* Versions 01.02 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:trutopsweld:*:*:*:*:*:*:*:* Versions 7.0.198.241 – 9.0.28148.1 Vulnerable ·TRUMPF
- cpe:2.3:a:trumpf:tubedesign:*:*:*:*:*:*:*:* Versions 08.00 – 14.06.150 Vulnerable ·TRUMPF
- cpe:2.3:a:phoenixcontact:activation_wizard:*:*:*:*:*:moryx:*:* Versions up to 1.6 Vulnerable ·Phoenixcontact
- cpe:2.3:a:phoenixcontact:e-mobility_charging_suite:*:*:*:*:*:*:*:* Versions up to 1.7.0 Vulnerable ·Phoenixcontact
- cpe:2.3:a:phoenixcontact:fl_network_manager:*:*:*:*:*:*:*:* Versions up to 7.0 Vulnerable ·Phoenixcontact
- cpe:2.3:a:phoenixcontact:iol-conf:*:*:*:*:*:*:*:* Versions up to 1.7.0 Vulnerable ·Phoenixcontact
- cpe:2.3:a:phoenixcontact:module_type_package_designer:*:*:*:*:*:*:*:* Versions before 1.2.0 Vulnerable ·Phoenixcontact
- cpe:2.3:a:phoenixcontact:module_type_package_designer:1.2.0:beta:*:*:*:*:*:* Versions 1.2.0 beta Vulnerable ·Phoenixcontact
- cpe:2.3:a:phoenixcontact:plcnext_engineer:*:*:*:*:*:*:*:* Versions up to 2023.6 Vulnerable ·Phoenixcontact
Remediation
- Fix · CNA CodeMeter Runtime (Wibu) Fixed in 7.21g
Timeline
- 2026-10-02 Threatist record created from CVE-2023-3935
- 2026-10-03 Alias added: GHSA-c9rf-qf73-r46f
References
More Wibu Codemeter Runtime vulnerabilities
- TI-2014-06916 Wibu-Systems CodeMeter Runtime before 5.20 uses weak permissions (read and write access… CVSS 2.0HIGH 7.2
- TI-2021-17910 In WIBU CodeMeter Runtime before 7.30a, creating a crafted CmDongles symbolic link will… CVSS 3.1HIGH 7.1
- TI-2011-03583 Wibu-Systems AG CodeMeter Runtime 4.30c, 4.10b, and possibly other versions before 4.40… CVSS 2.0MEDIUM 5.0
Sources
- CVE-2023-3935 · CVE Program
- CVE-2023-3935 · NVD
- FIRST EPSS
- GHSA-c9rf-qf73-r46f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences