Read the docs
TI-2023-03820 Aliases CVE-2023-4125GHSA-j63x-f657-2m9g

Weak Password Requirements in answerdev/answer

Priority HIGH 73CWE-521Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-521.

Summary

Weak Password Requirements in GitHub repository answerdev/answer prior to v1.1.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00883 59th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed answerdev/answer (answerdev): v1.1.0github.com/answerdev/answer (Go): 1.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
answerdevanswerdev/answerbefore v1.1.0v1.1.0Patch availableCNA
—github.com/answerdev/answer (Go)before 1.1.01.1.0Patch availableGHSA-j63x-f657-2m9g
  • answerdev/answer Vendoranswerdev Affected before v1.1.0 Fixed in v1.1.0 Patch available CNA
  • github.com/answerdev/answer (Go) Vendor— Affected before 1.1.0 Fixed in 1.1.0 Patch available GHSA-j63x-f657-2m9g

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:answer:answer:*:*:*:*:*:*:*:*before 1.1.0Vulnerableanswerdev
  • cpe:2.3:a:answer:answer:*:*:*:*:*:*:*:* Versions before 1.1.0 Vulnerable ·answerdev

Remediation

  • Fix · CNA answerdev/answer (answerdev) Fixed in v1.1.0
  • Fix · GHSA-j63x-f657-2m9g github.com/answerdev/answer (Go) Fixed in 1.1.0 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    answerdev/answer v1.1.0

    2 records Highest priority Priority HIGH 2 HIGH

    Other records, highest priority first

    • TI-2023-03821 Insufficient Session Expiration in answerdev/answerPriority HIGH 71

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4125
  2. 2026-10-03 Alias added: GHSA-j63x-f657-2m9g

References

  • TI-2023-00706 Improper Access Control in answerdev/answer CVSS 3.1CRITICAL 9.8
  • TI-2023-01451 Authentication Bypass by Capture-replay in answerdev/answer CVSS 3.1CRITICAL 9.8
  • TI-2023-00705 Cross-site Scripting (XSS) - Generic in answerdev/answer CVSS 3.1CRITICAL 9.0
  • TI-2023-00704 Cross-site Scripting (XSS) - Stored in answerdev/answer CVSS 3.1CRITICAL 9.0
  • TI-2023-00703 Cross-site Scripting (XSS) - DOM in answerdev/answer CVSS 3.1CRITICAL 9.0
  • TI-2023-00702 Cross-site Scripting (XSS) - Stored in answerdev/answer CVSS 3.1CRITICAL 9.0
See all 33 →

Sources