Read the docs
TI-2023-03965 Aliases CVE-2023-4289GHSA-hg5g-m3rr-7xx2

WP Matterport Shortcode < 2.1.8 - Contributor+ Stored XSS via shortcode

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The WP Matterport Shortcode WordPress plugin before 2.1.8 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the contributor role and above to perform Stored Cross-Site Scripting attacks

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00471 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Matterport Shortcode (Unknown): 2.1.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Matterport Shortcodebefore 2.1.82.1.8Patch availableCNA
  • WP Matterport Shortcode VendorUnknown Affected before 2.1.8 Fixed in 2.1.8 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:mpembed:wp_matterport_shortcode:*:*:*:*:*:wordpress:*:*before 2.1.8VulnerableMpembed
  • cpe:2.3:a:mpembed:wp_matterport_shortcode:*:*:*:*:*:wordpress:*:* Versions before 2.1.8 Vulnerable ·Mpembed

Remediation

  • Fix · CNA WP Matterport Shortcode (Unknown) Fixed in 2.1.8

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4289
  2. 2026-10-03 Alias added: GHSA-hg5g-m3rr-7xx2

References

  • TI-2023-03966 WP Matterport Shortcode < 2.1.7 - Reflected XSS CVSS 3.1MEDIUM 6.1
  • TI-2023-17564 WordPress WP Matterport Shortcode Plugin <= 2.1.4 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources