wpDataTables < 2.1.66 - Admin+ PHP Object Injection
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The wpDataTables WordPress plugin before 2.1.66 does not validate the "Serialized PHP array" input data before deserializing the data. This allows admins to deserialize arbitrary data which may lead to remote code execution if a suitable gadget chain is present on the server. This is impactful in environments where admin users should not be allowed to execute arbitrary code, such as multisite.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | wpDataTables | before 2.1.66 | 2.1.66 | Patch available | CNA |
- wpDataTables VendorUnknown Affected before 2.1.66 Fixed in 2.1.66 Patch available CNA
Remediation
- Fix · CNA wpDataTables (Unknown) Fixed in 2.1.66
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4314
- 2026-10-03 Alias added: GHSA-j3w9-3jjx-5qp2
References
More TMS Wpdatatables vulnerabilities
- TI-2021-06490 wpDataTables < 3.4.2 - Improper Access Control leading to Table Data Deletion CVSS 3.1HIGH 8.1
- TI-2021-06489 wpDataTables < 3.4.2 - Improper Access Control leading to Table Permission Takeover CVSS 3.1HIGH 8.1
- TI-2021-06492 wpDataTables < 3.4.2 - Blind SQL Injection via length Parameter CVSS 3.1MEDIUM 6.5
- TI-2021-06491 wpDataTables < 3.4.2 - Blind SQL Injection via start Parameter CVSS 3.1MEDIUM 6.5
- TI-2023-09675 WordPress wpDataTables Plugin <= 2.1.49 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2024-00547 wpDataTables – WordPress Data Table, Dynamic Tables & Table Charts Plugin <= 3.4.2.2 - Reflected Cross-Site Scripting. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2023-4314 · CVE Program
- CVE-2023-4314 · NVD
- FIRST EPSS
- GHSA-j3w9-3jjx-5qp2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences