Read the docs
TI-2023-04167 Aliases CVE-2023-4515GHSA-j2x9-qg6q-8wg7

ksmbd: validate command request size

Priority LOW 39Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

In the Linux kernel, the following vulnerability has been resolved: ksmbd: validate command request size In commit 2b9b8f3b68ed ("ksmbd: validate command payload size"), except for SMB2_OPLOCK_BREAK_HE command, the request size of other commands is not checked, it's not expected. Fix it by add check for request size of other commands.

Why it matters now

EPSS 0.00328 26th percentileScored 2026-11-07
Fix Fixed Linux (Linux): 5.15.127, 6.1.46, 6.4 +2

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
LinuxLinux5.15.121 to before 5.15.127; 6.1.36 to before 6.1.46; 6.3.10 to before 6.45.15.127, 6.1.46, 6.4Patch availableCNA
LinuxLinux6.4 and later5.15.127, 6.1.46, 6.4.11, 6.5Patch availableCNA
  • Linux VendorLinux Affected 5.15.121 to before 5.15.127; 6.1.36 to before 6.1.46; 6.3.10 to before 6.4 Fixed in 5.15.127, 6.1.46, 6.4 Patch available CNA
  • Linux VendorLinux Affected 6.4 and later Fixed in 5.15.127, 6.1.46, 6.4.11, 6.5 Patch available CNA

CPE configurations NVD · 7

CPEVersionsRoleVendor
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*5.15.121 to before 5.15.127; 6.1.36 to before 6.1.46; 6.3.10 to before 6.4; 6.4.1 to before 6.4.11VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.4:-:*:*:*:*:*:*6.4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.5:rc1:*:*:*:*:*:*6.5 rc1VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.5:rc2:*:*:*:*:*:*6.5 rc2VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.5:rc3:*:*:*:*:*:*6.5 rc3VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.5:rc4:*:*:*:*:*:*6.5 rc4VulnerableLinux
cpe:2.3:o:linux:linux_kernel:6.5:rc5:*:*:*:*:*:*6.5 rc5VulnerableLinux
  • cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:* Versions 5.15.121 to before 5.15.127; 6.1.36 to before 6.1.46; 6.3.10 to before 6.4; 6.4.1 to before 6.4.11 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.4:-:*:*:*:*:*:* Versions 6.4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.5:rc1:*:*:*:*:*:* Versions 6.5 rc1 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.5:rc2:*:*:*:*:*:* Versions 6.5 rc2 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.5:rc3:*:*:*:*:*:* Versions 6.5 rc3 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.5:rc4:*:*:*:*:*:* Versions 6.5 rc4 Vulnerable ·Linux
  • cpe:2.3:o:linux:linux_kernel:6.5:rc5:*:*:*:*:*:* Versions 6.5 rc5 Vulnerable ·Linux

Remediation

  • Fix · CNA Linux (Linux) Fixed in 5.15.127, 6.1.46, 6.4
  • Fix · CNA Linux (Linux) Fixed in 5.15.127, 6.1.46, 6.4.11, 6.5

Vendor assessments

Red Hat

Red Hat rating: Low. Red Hat's page for this CVE →

Not affected: 5 products
  • Red Hat Enterprise Linux 10
  • Red Hat Enterprise Linux 6
  • Red Hat Enterprise Linux 7
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux 9

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4515
  2. 2026-10-03 Alias added: GHSA-j2x9-qg6q-8wg7
  3. 2026-11-07 Affected versions changed · Red Hat

References

  • TI-2025-26358 tls: fix handling of zero-length records on the rx_list KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-38352 netfilter: bridge: make ebt_snat ARP rewrite writable KEVCVSS 3.1HIGH 8.8
  • TI-2013-05264 The (1) get_user and (2) put_user API functions in the Linux kernel before 3.5.5 on the… KEVCVSS 3.1HIGH 8.8
  • TI-2022-00125 Integer overflow in kernel KEVCVSS 3.1HIGH 8.4
  • TI-2013-01864 The perf_swevent_init function in kernel/events/core.c in the Linux kernel before 3.8.9… KEVCVSS 3.1HIGH 8.4
  • TI-2021-05514 Heap Out-Of-Bounds Write in Netfilter IP6T_SO_SET_REPLACE KEVCVSS 3.1HIGH 8.3
See all 15278 →

Sources