Read the docs
TI-2023-04398 Aliases CVE-2023-4771GHSA-wh5w-82f3-wrxh

Cross-Site Scripting vulnerability in CKSource CKEditor

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

A Cross-Site scripting vulnerability has been found in CKSource CKEditor affecting versions 4.15.1 and earlier. An attacker could send malicious javascript code through the /ckeditor/samples/old/ajax.html file and retrieve an authorized user's information.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00878 59th percentileScored 2026-11-07
Fix Fixed ckeditor4 (npm): 4.24.0-lts

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
CKSourceCKEditorup to 4.15.1—No fix listedCNA
—ckeditor4 (npm)before 4.24.0-lts4.24.0-ltsPatch availableGHSA-wh5w-82f3-wrxh
  • CKEditor VendorCKSource Affected up to 4.15.1 Fixed in — No fix listed CNA
  • ckeditor4 (npm) Vendor— Affected before 4.24.0-lts Fixed in 4.24.0-lts Patch available GHSA-wh5w-82f3-wrxh

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:cksource:ckeditor:*:*:*:*:*:wordpress:*:*up to 4.15.1VulnerableCKSource
  • cpe:2.3:a:cksource:ckeditor:*:*:*:*:*:wordpress:*:* Versions up to 4.15.1 Vulnerable ·CKSource

Remediation

  • Fix · GHSA-wh5w-82f3-wrxh ckeditor4 (npm) Fixed in 4.24.0-lts Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4771
  2. 2026-10-03 Alias added: GHSA-wh5w-82f3-wrxh

References

  • TI-2015-07726 The ckeditor-for-wordpress plugin before 4.5.3.1 for WordPress has reflected XSS in the "built-in (old)" file browser. CVSS 3.0MEDIUM 6.1

Sources