Incorrect Authorization in GitLab
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-863.
Summary
An issue has been discovered in GitLab EE affecting all versions starting from 15.3 before 16.5.6, all versions starting from 16.6 before 16.6.4, all versions starting from 16.7 before 16.7.2. The required CODEOWNERS approval could be bypassed by adding changes to a previously approved merge request.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 15.3 to before 16.5.6; 16.6 to before 16.6.4; 16.7 to before 16.7.2 | 16.5.6, 16.6.4, 16.7.2 | Patch available | CNA |
- GitLab VendorGitLab Affected 15.3 to before 16.5.6; 16.6 to before 16.6.4; 16.7 to before 16.7.2 Fixed in 16.5.6, 16.6.4, 16.7.2 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 15.3.0 to before 16.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 15.3.0 to before 16.5.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.6.0 to before 16.6.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.6.0 to before 16.6.4 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.7.0:*:*:*:enterprise:*:*:* | 16.7.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.7.1:*:*:*:enterprise:*:*:* | 16.7.1 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 15.3.0 to before 16.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 15.3.0 to before 16.5.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.6.0 to before 16.6.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.6.0 to before 16.6.4 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.7.0:*:*:*:enterprise:*:*:* Versions 16.7.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.7.1:*:*:*:enterprise:*:*:* Versions 16.7.1 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.5.6, 16.6.4, 16.7.2
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
GitLab 16.5.6, 16.6.4, 16.7.2
4 records Highest priority Priority MEDIUM 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2023-04929 Incorrect Authorization in GitLabPriority MEDIUM 40
- TI-2023-06357 Missing Authorization in GitLabPriority LOW 30
- TI-2023-01907 Improper Verification of Cryptographic Signature in GitLabPriority LOW 24
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4812
- 2026-10-03 Alias added: GHSA-5q5j-r39w-wc64
References
Exploit 1
Other 1
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-4812 · CVE Program
- CVE-2023-4812 · NVD
- FIRST EPSS
- GHSA-5q5j-r39w-wc64 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences