iframe <= 4.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'iframe' Shortcode
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The iframe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `iframe` shortcode in versions up to, and including, 4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permission and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 4.6 and fully patched in version 4.7.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| webvitaly | iframe | up to 4.6 | — | No fix listed | CNA |
- iframe Vendorwebvitaly Affected up to 4.6 Fixed in — No fix listed CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:iframe_project:iframe:*:*:*:*:*:wordpress:*:* | before 4.7 | Vulnerable | Iframe Project |
- cpe:2.3:a:iframe_project:iframe:*:*:*:*:*:wordpress:*:* Versions before 4.7 Vulnerable ·Iframe Project
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-4919
- 2026-10-03 Alias added: GHSA-fhx9-p329-4x23
References
Exploit 2
More webvitaly vulnerabilities
- TI-2025-22046 WordPress Sitekit plugin <= 1.8 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-34800 WordPress Magic Slider plugin <= 1.3 - Stored Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2024-19285 WordPress Sitekit plugin <= 1.6 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-38433 WordPress Extra Shortcodes plugin <= 2.2 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-36034 WordPress Sitekit Plugin <= 2.0 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
- TI-2025-35882 WordPress Page-list Plugin <= 5.8 - Cross Site Scripting (XSS) Vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-4919 · CVE Program
- CVE-2023-4919 · NVD
- FIRST EPSS
- GHSA-fhx9-p329-4x23 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences