Read the docs
TI-2023-04556 Aliases CVE-2023-4947GHSA-jhg8-jx4g-7x8h

WooCommerce EAN Payment Gateway < 6.1.0 - Missing Authorization to Authenticated (Contributor+) EAN Update

Priority LOW 20CWE-862Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.

Summary

The WooCommerce EAN Payment Gateway plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the refresh_order_ean_data AJAX action in versions up to 6.1.0. This makes it possible for authenticated attackers with contributor-level access and above, to update EAN numbers for orders.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00435 38th percentileScored 2026-11-07
Fix Fixed WooCommerce EAN Payment Gateway (Yan&Co): 6.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Yan&CoWooCommerce EAN Payment Gatewaybefore 6.1.06.1.0Patch availableCNA
  • WooCommerce EAN Payment Gateway VendorYan&Co Affected before 6.1.0 Fixed in 6.1.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:yanco:woocommerce_ean_payment_gateway:*:*:*:*:*:wordpress:*:*before 6.1.0VulnerableYanco
  • cpe:2.3:a:yanco:woocommerce_ean_payment_gateway:*:*:*:*:*:wordpress:*:* Versions before 6.1.0 Vulnerable ·Yanco

Remediation

  • Fix · CNA WooCommerce EAN Payment Gateway (Yan&Co) Fixed in 6.1.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4947
  2. 2026-10-03 Alias added: GHSA-jhg8-jx4g-7x8h

References

Sources