Pgadmin4: remote code execution by an authenticated user
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
A flaw was found in pgAdmin. This issue occurs when the pgAdmin server HTTP API validates the path a user selects to external PostgreSQL utilities such as pg_dump and pg_restore. Versions of pgAdmin prior to 7.6 failed to properly control the server code executed on this API, allowing an authenticated user to run arbitrary commands on the server.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pgadmin4 | — | 7.7 | Patch available | CNA |
| — | pgadmin4 (PyPI) | before 7.7 | 7.7 | Patch available | GHSA-ghp8-52vx-77j4 |
- pgadmin4 Vendor— Affected — Fixed in 7.7 Patch available CNA
- pgadmin4 (PyPI) Vendor— Affected before 7.7 Fixed in 7.7 Patch available GHSA-ghp8-52vx-77j4
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* | before 7.7 | Vulnerable | pgadmin.org |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* Versions before 7.7 Vulnerable ·pgadmin.org
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA pgadmin4 Fixed in 7.7
- Fix · GHSA-ghp8-52vx-77j4 pgadmin4 (PyPI) Fixed in 7.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5002
- 2026-10-03 Alias added: GHSA-ghp8-52vx-77j4
References
Other 6
- https://lists.fedoraproject.org/archives/list/[email protected]/message/2S24D3S2GVNGTDNE6SF2OQSOPU3H72UW/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/VIRTMQZEE6K7RD37ERZ2UFYFLEUXLQU3/
- https://github.com/pgadmin-org/pgadmin4/commit/35f05e49b3632a0a674b9b36535a7fe2d93dd0c2
- https://github.com/pgadmin-org/pgadmin4
- https://lists.fedoraproject.org/archives/list/[email protected]/message/2S24D3S2GVNGTDNE6SF2OQSOPU3H72UW
- https://lists.fedoraproject.org/archives/list/[email protected]/message/VIRTMQZEE6K7RD37ERZ2UFYFLEUXLQU3
Sources
- CVE-2023-5002 · CVE Program
- CVE-2023-5002 · NVD
- FIRST EPSS
- GHSA-ghp8-52vx-77j4 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-5002 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences