Vault's Google Cloud Secrets Engine Removed Existing IAM Conditions When Creating / Updating Rolesets
Priority LOW 36CWE-266Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-266.
Summary
The Vault and Vault Enterprise ("Vault") Google Cloud secrets engine did not preserve existing Google Cloud IAM Conditions upon creating or updating rolesets. Fixed in Vault 1.13.0.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00514 44th percentileScored 2026-11-07
Fix Partial Vault (HashiCorp): 1.13.0Vault Enterprise (HashiCorp): 1.13.0+1 more productRed Hat: 2 advisoriesRed Hat: 2 fixed, 2 without a fix
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| HashiCorp | Vault | 0.10.0 to before 1.13.0 | 1.13.0 | Patch available | CNA |
| HashiCorp | Vault Enterprise | 0.10.0 to before 1.13.0 | 1.13.0 | Patch available | CNA |
| — | github.com/hashicorp/vault (Go) | before 1.13.0 | 1.13.0 | Patch available | GHSA-86c6-3g63-5w64 |
- Vault VendorHashiCorp Affected 0.10.0 to before 1.13.0 Fixed in 1.13.0 Patch available CNA
- Vault Enterprise VendorHashiCorp Affected 0.10.0 to before 1.13.0 Fixed in 1.13.0 Patch available CNA
- github.com/hashicorp/vault (Go) Vendor— Affected before 1.13.0 Fixed in 1.13.0 Patch available GHSA-86c6-3g63-5w64
Remediation
- Fix · CNA Vault (HashiCorp) Fixed in 1.13.0
- Fix · CNA Vault Enterprise (HashiCorp) Fixed in 1.13.0
- Fix · GHSA-86c6-3g63-5w64 github.com/hashicorp/vault (Go) Fixed in 1.13.0 Advisory →
Red Hat 2 advisories
- RHSA-2024:3718 Released 2024-10-01 · Red Hat rating ModerateOpenShift Container Platform 4.17.0 bug fix and security update
- Red Hat OpenShift Container Platform 4.17 openshift4/aws-kms-encryption-provider-rhel9, openshift4/azure-kms-encryption-provider-rhel9, openshift4/cloud-network-config-controller-rhel9 +47
- RHSA-2023:6832 Released 2023-11-08 · Red Hat rating ImportantRed Hat OpenShift Data Foundation 4.14.0 security, enhancement & bug fix update
- RHODF 4.14 for RHEL 9 odf4/cephcsi-rhel9, odf4/mcg-cli-rhel9, odf4/mcg-core-rhel9 +12
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Openshift Container Storage 4 | Affected | No fix planned: Out of support scope |
| Red Hat Openshift Data Foundation 4 | Affected | No fix yet |
| RHODF 4.14 for RHEL 9 | Fixed | RHSA-2023:6832 |
| Red Hat OpenShift Container Platform 4.17 | Fixed | RHSA-2024:3718 |
Not affected: 4 products
- RHODF 4.14 for RHEL 9
- Red Hat OpenShift Container Platform 4
- Red Hat OpenShift Container Platform 4.17
- Red Hat Openshift Data Foundation 4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5077
- 2026-10-03 Alias added: GHSA-86c6-3g63-5w64
References
More HashiCorp Vault vulnerabilities
- TI-2024-01904 Vault Cert Auth Method Did Not Correctly Validate Non-CA Certificates CVSS 3.1CRITICAL 9.8
- TI-2022-19053 An issue was discovered in HashiCorp Vault and Vault Enterprise before 1.11.3. CVSS 3.1CRITICAL 9.1
- TI-2020-17874 The official vault docker images before 0.11.6 contain a blank password for a root user. CVSS 3.1CRITICAL 9.8
- TI-2020-10142 HashiCorp Vault and Vault Enterprise 1.4.0 and 1.4.1, when configured with the GCP… CVSS 3.1CRITICAL 9.8
- TI-2026-04407 Vault Vulnerable to Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS CVSS 3.1HIGH 8.6
- TI-2025-05421 Arbitrary Remote Code Execution via Plugin Catalog Abuse CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-5077 · CVE Program
- CVE-2023-5077 · NVD
- FIRST EPSS
- GHSA-86c6-3g63-5w64 · GitHub Advisory Database · CC BY 4.0
- CVE-2023-5077 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences