WP Discord Invite < 2.5.2 - Admin+ Stored Cross Site Scripting
Priority MEDIUM 55CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Discord Invite WordPress plugin before 2.5.2 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0047 40th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed WP Discord Invite (Unknown): 2.5.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Discord Invite | before 2.5.2 | 2.5.2 | Patch available | CNA |
- WP Discord Invite VendorUnknown Affected before 2.5.2 Fixed in 2.5.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sarveshmrao:wp_discord_invite:*:*:*:*:*:wordpress:*:* | before 2.5.2 | Vulnerable | Sarvesh M Rao |
- cpe:2.3:a:sarveshmrao:wp_discord_invite:*:*:*:*:*:wordpress:*:* Versions before 2.5.2 Vulnerable ·Sarvesh M Rao
Remediation
- Fix · CNA WP Discord Invite (Unknown) Fixed in 2.5.2
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5181
- 2026-10-03 Alias added: GHSA-fwgv-8gvm-4fwm
References
More Sarvesh M Rao Wp Discord Invite vulnerabilities
- TI-2023-04608 WP Discord Invite < 2.5.1 - Arbitrary Settings Update via CSRF CVSS 3.1MEDIUM 6.5
Sources
- CVE-2023-5181 · CVE Program
- CVE-2023-5181 · NVD
- FIRST EPSS
- GHSA-fwgv-8gvm-4fwm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences