Execution with Unnecessary Privileges in GitLab
Priority MEDIUM 43CWE-250Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-250.
Summary
A vulnerability was discovered in GitLab CE and EE affecting all versions starting 16.0 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1. An authenticated attacker could perform arbitrary pipeline execution under the context of another user.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.01241 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA
Fix Fixed GitLab (GitLab): 16.4.1, 16.3.5, 16.2.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| GitLab | GitLab | 16.4 to before 16.4.1; 16.3 to before 16.3.5; 16.0.0 to before 16.2.8 | 16.4.1, 16.3.5, 16.2.8 | Patch available | CNA |
- GitLab VendorGitLab Affected 16.4 to before 16.4.1; 16.3 to before 16.3.5; 16.0.0 to before 16.2.8 Fixed in 16.4.1, 16.3.5, 16.2.8 Patch available CNA
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.0.0 to before 16.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.0.0 to before 16.2.8 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* | 16.3.0 to before 16.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* | 16.3.0 to before 16.3.5 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.4.0:*:*:*:community:*:*:* | 16.4.0 | Vulnerable | GitLab |
| cpe:2.3:a:gitlab:gitlab:16.4.0:*:*:*:enterprise:*:*:* | 16.4.0 | Vulnerable | GitLab |
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.0.0 to before 16.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.0.0 to before 16.2.8 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:* Versions 16.3.0 to before 16.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:* Versions 16.3.0 to before 16.3.5 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.4.0:*:*:*:community:*:*:* Versions 16.4.0 Vulnerable ·GitLab
- cpe:2.3:a:gitlab:gitlab:16.4.0:*:*:*:enterprise:*:*:* Versions 16.4.0 Vulnerable ·GitLab
Remediation
- Fix · CNA GitLab (GitLab) Fixed in 16.4.1, 16.3.5, 16.2.8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
Not affected: 1 product
- Red Hat OpenShift Container Platform 4
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5207
- 2026-10-03 Alias added: GHSA-m4hq-98c3-4xmx
References
More Gitlab vulnerabilities
- TI-2026-71508 Integer overflow in GitLab allows code execution on the server KEVCVSS 3.1CRITICAL 10.0
- TI-2026-58817 Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2023-06425 Weak Password Recovery Mechanism for Forgotten Password in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05191 Code injection in GitLab KEVCVSS 3.1CRITICAL 10.0
- TI-2021-05161 Server-side request forgery in GitLab KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02763 Injection in GitLab CVSS 3.1CRITICAL 9.9
Sources
- CVE-2023-5207 · CVE Program
- CVE-2023-5207 · NVD
- FIRST EPSS
- GHSA-m4hq-98c3-4xmx · GitHub Advisory Database · CC BY 4.0
- CVE-2023-5207 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences