AI ChatBot <= 4.8.9 and 4.9.2- Authenticated (Subscriber+) Arbitrary File Deletion via qcld_openai_delete_training_file
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The AI ChatBot plugin for WordPress is vulnerable to Arbitrary File Deletion in versions up to, and including, 4.8.9 as well as version 4.9.2. This makes it possible for authenticated attackers with subscriber privileges to delete arbitrary files on the server, which makes it possible to take over affected sites as well as others sharing the same hosting account. Version 4.9.1 originally addressed the issue, but it was reintroduced in 4.9.2 and fixed again in 4.9.3.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| quantumcloud | WPBot – AI ChatBot for Live Support, Lead Generation, AI Services | up to 4.8.9; 4.9.2 | — | No fix listed | CNA |
- WPBot – AI ChatBot for Live Support, Lead Generation, AI Services Vendorquantumcloud Affected up to 4.8.9; 4.9.2 Fixed in — No fix listed CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:quantumcloud:wpbot:*:*:*:*:*:wordpress:*:* | before 4.9.1 | Vulnerable | quantumcloud |
| cpe:2.3:a:quantumcloud:wpbot:4.9.2:*:*:*:*:wordpress:*:* | 4.9.2 | Vulnerable | quantumcloud |
- cpe:2.3:a:quantumcloud:wpbot:*:*:*:*:*:wordpress:*:* Versions before 4.9.1 Vulnerable ·quantumcloud
- cpe:2.3:a:quantumcloud:wpbot:4.9.2:*:*:*:*:wordpress:*:* Versions 4.9.2 Vulnerable ·quantumcloud
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5212
- 2026-10-03 Alias added: GHSA-phr8-8r83-j89w
References
Advisory 2
More quantumcloud Wpbot vulnerabilities
- TI-2023-01552 ChatBot < 4.4.7 - Unauthenticated PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2023-01558 ChatBot < 4.4.9 - Unauthenticated Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-00958 ChatBot < 4.4.5 - Stored XSS via CSRF CVSS 3.1MEDIUM 6.1
- TI-2023-01553 ChatBot < 4.4.9 - Subscriber+ OpenAI Settings Update to Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2025-00264 AI ChatBot for WordPress – WPBot < 6.2.4 - Admin+ Stored XSS CVSS 3.1MEDIUM 4.8
- TI-2023-03940 Chatbot < 4.7.8 - Admin+ Stored XSS in Language Settings CVSS 3.1MEDIUM 4.8
Sources
- CVE-2023-5212 · CVE Program
- CVE-2023-5212 · NVD
- FIRST EPSS
- GHSA-phr8-8r83-j89w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences