CVE-2023-5214 - Privilege Escalation in Puppet Bolt
Priority MEDIUM 42CWE-269Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-269.
Summary
In Puppet Bolt versions prior to 3.27.4, a path to escalate privileges was identified.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00447 39th percentileScored 2026-11-07
Fix Fixed bolt (RubyGems): 3.27.4
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Puppet | Bolt | prior to 3.27.4 – 3.27.4 | — | No fix listed | CNA |
| — | bolt (RubyGems) | before 3.27.4 | 3.27.4 | Patch available | GHSA-289m-2964-f8q5 |
- Bolt VendorPuppet Affected prior to 3.27.4 – 3.27.4 Fixed in — No fix listed CNA
- bolt (RubyGems) Vendor— Affected before 3.27.4 Fixed in 3.27.4 Patch available GHSA-289m-2964-f8q5
Remediation
- Fix · GHSA-289m-2964-f8q5 bolt (RubyGems) Fixed in 3.27.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5214
- 2026-10-03 Alias added: GHSA-289m-2964-f8q5
References
Advisory 2
Sources
- CVE-2023-5214 · CVE Program
- CVE-2023-5214 · NVD
- FIRST EPSS
- GHSA-289m-2964-f8q5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences