Five Star Restaurant Menu and Food Ordering < 2.4.11 - Unauthenticated PHP Object Injection
Priority HIGH 82CWE-74Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
The Five Star Restaurant Menu and Food Ordering WordPress plugin before 2.4.11 unserializes user input via an AJAX action available to unauthenticated users, allowing them to perform PHP Object Injection when a suitable gadget is present on the blog.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.01245 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Five Star Restaurant Menu and Food Ordering (Unknown): 2.4.11
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Five Star Restaurant Menu and Food Ordering | before 2.4.11 | 2.4.11 | Patch available | CNA |
- Five Star Restaurant Menu and Food Ordering VendorUnknown Affected before 2.4.11 Fixed in 2.4.11 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fivestarplugins:five_star_restaurant_menu:*:*:*:*:*:wordpress:*:* | before 2.4.11 | Vulnerable | Five Star Plugins |
- cpe:2.3:a:fivestarplugins:five_star_restaurant_menu:*:*:*:*:*:wordpress:*:* Versions before 2.4.11 Vulnerable ·Five Star Plugins
Remediation
- Fix · CNA Five Star Restaurant Menu and Food Ordering (Unknown) Fixed in 2.4.11
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5340
- 2026-10-03 Alias added: GHSA-v88m-92x2-qxm5
References
More Five Star Plugins Five Star Restaurant Menu vulnerabilities
- TI-2020-17543 The food-and-drink-menu plugin through 2.2.0 for WordPress allows remote attackers to… CVSS 3.1CRITICAL 9.8
- TI-2023-19417 WordPress Five Star Restaurant Menu Plugin <= 2.4.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-16883 WordPress Five Star Restaurant Reservations Plugin <= 2.6.7 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-16355 WordPress Five Star Restaurant Reviews Plugin <= 2.3.5 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2024-05073 Restaurant Menu and Food Ordering <= 2.4.16 - Missing Authorization to Menu Creation CVSS 3.1MEDIUM 4.3
Sources
- CVE-2023-5340 · CVE Program
- CVE-2023-5340 · NVD
- FIRST EPSS
- GHSA-v88m-92x2-qxm5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences