Product Catalog Enquiry for WooCommerce < 5.0.3 - Unauthenticated Stored XSS via Arbitrary Setting Update
Priority LOW 28CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Product Catalog Mode For WooCommerce WordPress plugin before 5.0.3 does not properly authorize settings updates or escape settings values, leading to stored XSS by unauthenticated users.
Why it matters now
EPSS 0.00531 45th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Product Catalog Mode For WooCommerce (Unknown): 5.0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Product Catalog Mode For WooCommerce | before 5.0.3 | 5.0.3 | Patch available | CNA |
- Product Catalog Mode For WooCommerce VendorUnknown Affected before 5.0.3 Fixed in 5.0.3 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:multivendorx:product_catalog_mode_for_woocommerce:*:*:*:*:*:wordpress:*:* | before 5.0.3 | Vulnerable | MultiVendorX |
- cpe:2.3:a:multivendorx:product_catalog_mode_for_woocommerce:*:*:*:*:*:wordpress:*:* Versions before 5.0.3 Vulnerable ·MultiVendorX
Remediation
- Fix · CNA Product Catalog Mode For WooCommerce (Unknown) Fixed in 5.0.3
Timeline
- 2026-10-02 Threatist record created from CVE-2023-5348
- 2026-10-03 Alias added: GHSA-v6cw-g4v9-gjmf
References
More MultiVendorX Product Catalog Mode For Woocommerce vulnerabilities
- TI-2024-17029 WordPress Product Catalog Mode For Woocommerce plugin <= 5.0.5 - Broken Access Control vulnerability CVSS 3.1CRITICAL 9.1
Sources
- CVE-2023-5348 · CVE Program
- CVE-2023-5348 · NVD
- FIRST EPSS
- GHSA-v6cw-g4v9-gjmf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences