Read the docs
TI-2023-05087 Aliases CVE-2023-5529GHSA-23vm-fxf4-h89x

Advanced Page Visit Counter <= 8.0.6 - Admin+ Stored XSS

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.

Summary

The Advanced Page Visit Counter WordPress plugin before 8.0.6 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00389 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Advanced Page Visit Counter (Unknown): 8.0.6

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownAdvanced Page Visit Counterbefore 8.0.68.0.6Patch availableCNA
  • Advanced Page Visit Counter VendorUnknown Affected before 8.0.6 Fixed in 8.0.6 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pagevisitcounter:advanced_page_visit_counter:*:*:*:*:*:wordpress:*:*up to 8.0.6VulnerablePage Visit Counter
  • cpe:2.3:a:pagevisitcounter:advanced_page_visit_counter:*:*:*:*:*:wordpress:*:* Versions up to 8.0.6 Vulnerable ·Page Visit Counter

Remediation

  • Fix · CNA Advanced Page Visit Counter (Unknown) Fixed in 8.0.6

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-5529
  2. 2026-10-03 Alias added: GHSA-23vm-fxf4-h89x

References

  • TI-2023-24122 WordPress Advanced Page Visit Counter Plugin <= 7.1.1 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
  • TI-2023-13298 WordPress Advanced Page Visit Counter Plugin <= 6.4.2 is vulnerable to SQL Injection CVSS 3.1HIGH 8.8
  • TI-2023-27557 WordPress Advanced Page Visit Counter Plugin <= 8.0.6 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5

Sources